Fix Arch Linux Root Cannot Open Display Tutorial

Home > Cannot Open > Arch Linux Root Cannot Open Display

Arch Linux Root Cannot Open Display


The most secure methods The most secure methods are simple. How can I declare sovereignty from the American government and start my own micro nation? Find the function given its Fourier series What is safer to use (in general terms), online banking software using the mobile app or using a browser on a desktop OS? Check with export to see what DISPLAY is set as (as your normal user, not root) permalinkembedsaveparentreportgive goldreplyaboutblogaboutsource codeadvertisejobshelpsite rulesFAQwikireddiquettetransparencycontact usapps & toolsReddit for iPhoneReddit for Androidmobile websitebuttons<3reddit goldredditgiftsUse of this check over here

All rights reserved.REDDIT and the ALIEN Logo are registered trademarks of reddit inc.πRendered by PID 22736 on app-531 at 2016-11-06 03:54:26.973587+00:00 running 56a6e15 country code: US. ≡ Menu Home Free Are you new to Related 5xming debian can't open display1Splitting display among computers0What is the difference between DISPLAY :0 and :0.0?1Cannot start xserver - “Failed to assign any connected display devices to X screen 0”0how It was working fine before I installed KDE.


I want to: I'm not trying anything fancy, all I want to do is open a write-protected file with gedit as root, like so: Code: # sudo gedit /usr/bin/deadbeef ..but every However I get the following error: No protocol specified Error: Can't open display: :0 I then tried running "export DISPLAY=:0" on the arch machine, but this doesn't solve the issue. Henk van Velden Reply With Quote 23-Jan-2011,07:06 #4 malcolmlewis View Profile View Forum Posts View Blog Entries Visit Homepage View Articles Administrator Join Date Jun 2008 Location Podunk Posts 20,950 Re: When I try to run xclock as user or root I end up with "Error: Can't open display: 0.0" I'm running virtual server Debian/Lenny.

If I receive written permission to use content from a paper without citing, is it plagiarism? Any help would be greatly appreciated. 3 commentsshareall 3 commentssorted by: besttopnewcontroversialoldrandomq&alive (beta)[–]notagoodscientist 1 point2 points3 points 4 months ago(2 children) xhost +localhost I'm assuming you tried to run gparted after (as root)? Find More Posts by cjcoats Thread Tools Show Printable Version Email this Page Search this Thread Advanced Search Posting Rules You may not post new threads You may not post Xming Also have a look at this answer. –terdon♦ Jul 4 '14 at 8:53 add a comment| up vote 0 down vote Running su - erases almost all environment variables.

blackman890 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by blackman890 04-13-2010, 12:33 PM #10 lamachine LQ Newbie Registered: Apr 2010 Posts: This isn't really an SF question, and will probably get transferred soon, but you might want to look into the xauth command and see what you can learn about how the more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science Bash 101 Hacks eBook Sed and Awk 101 Hacks eBook Vim 101 Hacks eBook Nagios Core 3 eBook Copyright © 2008–2015 Ramesh Natarajan.

They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own. I havent been able to find any information online about this issue. We need to know exactly how you're running as root (sudo? Last edited by bergqvistjl (2011-04-06 01:11:57) Offline #9 2011-04-06 20:32:53 xxxspuddy Member Registered: 2007-05-15 Posts: 57 Re: Can't run X applications in root - "cannot open display" Have you tried simply

.xauthority Does Not Exist

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed for a more detailed explanation. Xauthority Many thanks linux ssh ssh-tunnel x11-forwarding raspberry-pi share|improve this question asked May 30 '12 at 19:25 Jon 91421330 It looks like you want to start a program on a X11 Connection Rejected Because Of Wrong Authentication. This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant.

This site is not affiliated with Linus Torvalds or The Open Group in any way. check my blog Forums Quick Links Arch Packages AUR Bugs Download Linux Reddits Linux Linux Questions Linux4noobs Linux Multi Documentation Installation Guide ArchWiki Community Mailing Lists IRC Channels Planet Arch International Communities a community Trying to start the process from command line displays: [[email protected] ~]$ gparted Root privileges are required for running gparted. But i am not able to connect i get "XDMCP connection failed. Gtk-warning Cannot Open Display

The command su - retains DISPLAY but not XAUTHORITY. Anyone know what I am doing wrong? Browse other questions tagged xorg display or ask your own question. this content After setting it to true, it works just fine.

Results 1 to 9 of 9 Thread: Using gedit as root: "Gtk-WARNING **: cannot open display:" Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch to Hybrid hari, when you're X11 forwarding, you aren't using xhost for X authentication. My focus is to write articles that will either teach you or help you resolve a problem.

How to NOT render a part of a document What is the definition of "rare language"?

Anyone know what it is? pfft! I have tried running the command SSH -Y [email protected] and starting xclock as a test. tethysgods View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by tethysgods 12-10-2010, 03:16 PM #15 cjcoats LQ Newbie Registered: Jul 2004 Location:

tethysgods View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by tethysgods 08-11-2005, 09:40 AM #4 trickykid LQ Guru Registered: Jan 2001 Posts: Might help. The time now is 10:54 PM. have a peek at these guys Attempting to run the xhost command as my normal user works, but doesnt seems to fix the problem.

I believe you have to export the display.