Fix Apache Cannot Error Load Php Php4apache.dll Tutorial

Home > Apache Cannot > Apache Cannot Error Load Php Php4apache.dll

Apache Cannot Error Load Php Php4apache.dll

You can configure PHP as Apache handler in <[apache_home]>\conf\httpd.conf as follow: LoadModule php5_module "c:/php/php5apache2_2.dll" AddHandler application/x-httpd-php .php #configure the path to php.ini PHPIniDir 'C:\php\' NOTE: To avoid the error while starting Please look at my attached config file and let me know what i am doing worng. You may have to register before you can post: click the register link above to proceed. But before that, I had to download the 'other' PHP4 file. check over here

Cf the download links here on the official site: http://windows.php.net/download/. Cannot load C:/php/sapi/php4apache.dll into server Web Server Configuration forum to discuss the problems and solutions of Apache and IIS Server configurations. Last updated: Sun Nov 06 03:01:35 2016 UTC php.net| support| documentation| report a bug| advanced search| search howto| statistics| random bug| login go to bug id or search bugs for Bug#16575 The dependency checker that comes with Visual Studio 6 reports that php4apache.dll depends on another dll called apachecore.dll, which didn't come with the php or apache binaries. https://bugs.php.net/bug.php?id=16575

share|improve this answer answered Nov 26 '14 at 4:42 Reedyseth 213 add a comment| up vote 0 down vote None of the suggestions above worked for me. I found out after following a particular Youtube tutorial that if you go and edit the httpd.conf file while Apache is running... windows. The dll worked despite 5.4.8 - 5.4.9 mismatch.

I am using the standard Win32 binary release for both PHP and Apache. I got MySQL installed and working too... Find all posts by nicat23 Find all threads by nicat23 Add nicat23 to Your Buddy List #3 April 3rd, 2003, 03:13 PM infamous-online Contributing User Join Date: Why does Friedberg say that the role of the determinant is less central than in former times?

BlazE Reply With Quote 07-04-2002,03:51 PM #30 Anon View Profile View Forum Posts Senior Member Join Date Jun 2000 Posts 65,357 RE: cannot load php4apache.dll in apache I have been having What is the definition of "rare language"? The corrsponding changes within "php.ini" and "httpd.conf" are to be maintained acoording to this helpful guide. https://bugs.php.net/bug.php?id=10969 I did not have to mess with the apache configuration as other people suggest.

The php4apache.dll file is in that patch so i just cant figure what the problem is Any ideas? Also in the future, please reference the posting rules. have tried by adding de following 2 lines! non, je parle perl) If this is not a red herring, perhaps some kind soul could fix this dependency. -d Reply With Quote 05-25-2002,09:39 PM #23 Anon View Profile View Forum

It is included only the Thread Safe version of PHP 5.4.38 http://windows.php.net/downloads/releases/php-5.4.38-Win32-VC9-x86.zip share|improve this answer answered Mar 19 '15 at 8:58 Laszlo Lugosi 2,21111011 add a comment| Your Answer draft I don't get any errors when I start Apache. Where can I get php error output in such cases (there is nothing in the apache logs)? I have installed previous apache and PHP.

PD: you can see where your extensions directory is located looking for the text "extension_dir" in your php.ini, sometimes looks like: extension_dir = C:\php\extensions Hope this help you, if not please check my blog Worth, TX Posts: 650 Time spent in forums: 1 h 48 m 34 sec Reputation Power: 0 I agree.. Here is the line from my httpd.conf file: LoadModule php4_module c:/php/sapi/php4apache.dll I get this error message when trying to start apache: ===================================================== Syntax error on line 182 of c:/program files/apache group/apache/httpd.conf: I tried backslashes instead which lets apache load but php won't work.I tried copying everything to my c: drive and updating the LoadModule line to point to C instead of F.

Patches Add a PatchPull Requests Add a Pull RequestHistoryAllCommentsChangesGit/SVN commitsRelated reports [2002-04-12 15:57 UTC] [email protected] You can't load the Apache 1 sapi into Apache 2. Grab PHP 4.2.0 RC3, which will include the file you need. [2002-04-26 16:44 UTC] luna at enst dot fr If it can help, I tried to make an installation doc at: share|improve this answer edited May 3 '14 at 12:55 Qantas 94 Heavy 9,974134158 answered May 3 '14 at 12:35 Goldie 1 add a comment| up vote 0 down vote I had this content To start viewing messages, select the forum that you want to visit from the selection below.

Player claims their wizard character knows everything (from books). Reply With Quote 05-02-2002,11:12 AM #20 Anon View Profile View Forum Posts Senior Member Join Date Jun 2000 Posts 65,357 RE: cannot load php4apache.dll in apache I have the same problem. ben should i write an article on this infamous-online View Public Profile View Extended RPG Stats Challenge This User To Battle Send a private message to infamous-online Find all posts by

On 1941 Dec 7, could Japan have destroyed the Panama Canal instead of Pearl Harbor in a surprise attack?

Thank you! I have Win98SEMy command is this:Apache.exe -w -f "C:\Program Files\Apache Group\Apache2\conf\httpd.conf" -d "C:\Program Files\Apache Group\Apache2\."The error is this:Syntax error on line 978 of C:/Program Files/Apache Group/Apache2/conf/httpd.conf:Cannot load F:/php/sapi/php4apache.dll into server: One I got up to the point where I dont see apache complaining about finding the library anymore, but now I get a windows dialog saying: "invalid library maybe not a php Why did the best potions master have greasy hair?

How do I sort files into a sub-folder based on filename part? For further reading try the install.txt that comes with PHP and read the "Manual Installation Steps" part and the "Apache 2.0.x on Microsoft Windows" part. I had the same problem on Win98 with Apache 2.0.39 and PHP 4.2.1 and used the line LoadModule php4_module path\php\sapi\php4apache2.dll and it worked. have a peek at these guys Install both packages, not only 2010 version.

APACHECORE.DLL PHP4TS.DLL ... it worked for me with the latest stable snap of php4 http://snaps.php.net ciao. Everything goes well, but phpinfo() shows the older version number etc. reply | permalink Micha hi, If you've installed PHP in c:\apps\PHP\ you must use LoadModule php4_module c:\apps\PHP\sapi\php4apache.dll (LoadModule php4_module c:/php/sapi/php4apache.dll won't work !) Arnaud wrote: -- Linux...

So make sure, that before your installation, there is no another php.ini or php4ts.dll on your computer!!! by the way, it's right you need the php4apache2.dll not php4apache.dll --- [email protected] (Jmr) wrote in news:[email protected]: Svenie at Nov 7, 2002 at 5:43 pm ⇧ hi,i had similar problems. kuikeelc View Public Profile View Extended RPG Stats Challenge This User To Battle Send a private message to kuikeelc Find all posts by kuikeelc Find all threads by kuikeelc Add kuikeelc there is no vc6 version for it –Terix Feb 14 '13 at 14:50 add a comment| up vote 1 down vote You are getting an error due to the fact that

I changed one method signature and broke 25,000 other classes. i guess you haven't replaced everything with the new build. [2001-05-03 10:06 UTC] sonnysavage at yahoo dot com I tried again, and here are the steps that I took: 1) I but had to install the .Net 4 Framework. After this Apache works fine . :) Hope this helps!

php.net| support| documentation| report a bug| advanced search| search howto| statistics| random bug| login go to bug id or search bugs for Bug#16575 cannot load php4apache.dll with apache2 Submitted: 2002-04-12 14:10 I copied the php.ini-recommended. Sameer Reply With Quote 02-05-2002,04:40 PM #19 gardner1 View Profile View Forum Posts Senior Member Join Date Sep 2001 Posts 113 RE: cannot load php4apache.dll in apache have you tried installing MyWeb « Previous Thread | Next Thread » Thread Tools Search this Thread Display Modes

Dev Articles Community Forums Sponsor: #1 April 3rd, 2003, 04:58

BTW others (from a newsgroup) seem to have the problem too, but still no solution...